Archiv

Kategorien

Archiv 2017

Archiv 2016
März (1)
Januar (1)

Archiv 2014
August (1)

Archiv 2013
Januar (1)

Archiv 2012
August (1)
Juni (2)
Januar (1)

Archiv 2011
Juli (2)
Januar (3)

Archiv 2010
August (2)
Juni (1)
März (2)
Januar (1)

Archiv 2009
August (2)
Juli (1)
Juni (1)
Mai (2)
April (4)
März (3)
Januar (1)

Archiv 2008
August (7)
Juli (2)
Juni (3)
Mai (7)
April (3)
März (5)
Januar (6)

Archiv 2007
August (3)
Juli (4)
Juni (2)
Mai (2)
April (4)
Januar (3)

Archiv 2006
August (2)
Juli (5)
Juni (3)
Mai (6)
April (5)
März (7)

Archiv 2005
August (1)
Januar (4)

Archiv 2004
August (3)
Juli (11)
Juni (2)
Mai (1)

News

83 Serverumzug und Downzeit

Beitragvon De_little_Bubi » 12.02.2009 - 04:38:50

Wie ihr vor der Downzeit wohl alle gemerkt habt, hatten wir große Performance Probleme und zwischendurch immer wieder Ausfälle.
Aus diesem Grund entschieden wir uns auf einen neuen besseren Server umzuziehen.
Durch den Einsatz unseres beliebten Serveradministrator Chrisco und unter meiner Aufsicht konnte diese sehr schnell und unkompliziert abgehandelt werden.
Ein schneller Blick auf die Seite und ins Forum lies vermuten, dass alles einwandfrei übertragen wurde.

Kurze Zeit später stellte sich heraus: Dem war nicht so :/ Wichtige Kernfunktionen des Forums funktionierten nicht mehr.
Darunter das verfassen von neuen Einträgen sowie das Registrieren.

Blöderweise kam bei mir die Klausurzeit dazwischen. Da konnte ich nicht einfach noch einmal einen Exkurs in die schöne Welt des PHP und des phpbb2 Forencodes machen.

Gestern schrieb ich die letzten 2. Und gleich heute Nacht habe ich mich dann ran gesetzt :) Und nach ein pa Stunden suche habe ich dann auch den Fehler gefunden. Ich will ihn euch nicht vorenthalten:

Das phpBB2 Forum benutzt eine alte nicht mehr benutzte Methode zur Übertragung der Daten aus dem Eingabefeld (da wo man einen neuen Post reinschreibt). Neuere PHP Versionen haben diese alte Variante nur noch aus Kompatibilitätsgründen mit sich rum geschleppt. Diese kann man natürlich ausschalten. Auf diesem neuen Server sind sie ausgeschaltet... Anschalten kann ich nicht, dafür müsste ich jetzt den Chrisco anrufen und der reist mir bei dieser Uhrzeit den Kopf ab.
Also weiter geschaut und gefunden! Das Board besitzt schon ein Fix, das es ermöglicht die neue Methode der Datenübertragung zu verwenden. Sogar schon voll automatisch.
Blöderweise wusste ich das nicht, als ich damals den Spambotschutz gebaut hatte. Dieser ist dadurch Inkompativel zu dieser Brücke geworden und jetzt wo die Brücke Aktiv ist, ist der Fehler zu sehen.

Wie dem auch sei, ich habe den Spambotschutz umgeschrieben. Er ist nun Kompatibel und wir haben immer noch unseren alten Schutz vor den Bots :) .

Sollte es noch weitere Probleme geben, bei mir melden bitte.

mfg.: De_little_Bubi
News ganz lesen: Hier
Link zum Thema: 83 Serverumzug und Downzeit
Kommentare: 13

Überlebende!

Beitragvon tetrodoxin » 12.02.2009 - 20:04:30

Jeder, der im Stande ist eine Waffe oder Sonstiges zu benutzen, was jemandem Schaden zufügen kann, soll sich am 15.2. um 20:00 ins Teamspeak begeben!
Die Untoten gewinnen mal wieder die Oberhand und es ist unser Job, sie aufzuhalten :O

Natürlich rede ich von Zombie Panic und dessen neue Version 1.5.1. Vor allem das neue Verbarrikadierungssystem reizt mal wieder für ein Event. Also, werft euren Autopatcher an (wenn nicht eh schon getan) und besorgt euch die neueste Version.
Wie üblich gilt, sich vorher zu melden oder abzusagen, damit gegebenenfalls das Datum und die Uhrzeit angepasst werden können.

Bild
Schmerzhaft: sich in der vordersten Reihe beim Saturn befinden, wenn ein WoW-Addon releast wird


Ebenfalls spreche ich Lob und Dank an Bubi aus, der Forenprobleme mal wieder souverän gelöst hat. Danke Bubi! :)
Zuletzt geändert von tetrodoxin am 13.02.2009 - 15:40:56, insgesamt 1-mal geändert.
News ganz lesen: Hier
Link zum Thema: Überlebende!
Kommentare: 4

cron